Centos 5安装最新版Eclipse全流程[未完]

首先,安装Eclipse最新版——其实就不需要安装,下下来解压就行,关键是解压后打不开,提示GTK+版本太低。

因此,安装GTK+

gtkversion
转官网下载:http://www.gtk.org/download/linux.php
而里面也说明需要几个依赖的软件。
首先依赖的GLib,而安装Glib首先又需要Libffi,故转至http://www.sourceware.org/libffi/下载.
Libffi安装:

tar -xvf libffi-***.tar.gz
cd libffi-**.tar.gz
./configure --prefix=/opt/libffi [/opt/libffi为自己配置安装目录]
make
make install

安装完成后,将pkg-config的位置添加到环境变量[不然安装Glib的时候总提示Libffi没有安装或者版本不对]

export PKG_CONFIG_PATH=/opt/libffi/lib/pkgconfig

在安装Glib之前还有一个问题,就是从官网下的Glib包tar解压不了,其格式为xz compressed data 故需要现用xz处理下[xz可以用yum安装下]
下面是步骤:

xz -d *****.tar.xz
tar -xvf *****.tar

在处理./configure时还有另外一个问题,Glib编译需要-march=i486
详细见http://www.ha97.com/book/lfs-book-6.6/chapter05/glibc.html
简单处理:

echo "CFLAGS += -march=i486 -mtune=native" > configparms ;
./configure --prefix=/opt/glib
make
make install
export PKG_CONFIG_PATH=/opt/glib/lib/pkgconfig

到此,Glib安装完成

下面安装Pango

Could not enable any backends.[被此问题困住了]

未完待续——问题还木有解决

相关网址:
http://bbs.csdn.net/topics/270043646
http://blog.csdn.net/ldl22847/article/details/8609651
https://developer.gnome.org/gtk3/stable/gtk-building.html

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*